import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+_[0-9]{3}\\.wmo$";
final String string = "DuskwooAbandoned_Barn.wmo\n"
+ "DuskwooAbandoned_Barn_000.wmo\n"
+ "DuskwooAbandoned_Barn_001.wmo\n"
+ "DuskwooAbandoned_Barn_002.wmo\n\n"
+ "DuskwooAbandoned_Barn01.wmo\n"
+ "DuskwooAbandoned_Barn01_000.wmo\n\n"
+ "DuskwooAbandoned_Barn_01.wmo\n"
+ "DuskwooAbandoned_Barn_01_000.wmo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}