// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.+_[0-9]{3}\.wmo$").unwrap();
let string = "DuskwooAbandoned_Barn.wmo
DuskwooAbandoned_Barn_000.wmo
DuskwooAbandoned_Barn_001.wmo
DuskwooAbandoned_Barn_002.wmo
DuskwooAbandoned_Barn01.wmo
DuskwooAbandoned_Barn01_000.wmo
DuskwooAbandoned_Barn_01.wmo
DuskwooAbandoned_Barn_01_000.wmo";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}