use strict;
my $str = 'DuskwooAbandoned_Barn.wmo
DuskwooAbandoned_Barn_000.wmo
DuskwooAbandoned_Barn_001.wmo
DuskwooAbandoned_Barn_002.wmo
DuskwooAbandoned_Barn01.wmo
DuskwooAbandoned_Barn01_000.wmo
DuskwooAbandoned_Barn_01.wmo
DuskwooAbandoned_Barn_01_000.wmo';
my $regex = qr/^.+_[0-9]{3}\.wmo$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}