#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{([\s\S]*equation\})\}"
Local $sString = "$str='\add[sometext]{\begin{equation}\label{eqn:3}" & @CRLF & _
"f_{1} =" & @CRLF & _
"\begin{cases}}" & @CRLF & _
"\beta_{1} + \beta_{2}f_{2} & f_{2}\leq \gamma\\" & @CRLF & _
"\beta_{1} + \beta_{2}\gamma + \beta_{4}(f_{2}-\gamma) & f_{2} >\gamma" & @CRLF & _
"\end{cases}sdsdssd," & @CRLF & _
"\end{equation}}'" & @CRLF & _
"" & @CRLF & _
"blablablaba {}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")