import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{([\\s\\S]*equation\\})\\}";
final String string = "$str='\\add[sometext]{\\begin{equation}\\label{eqn:3}\n"
+ "f_{1} =\n"
+ "\\begin{cases}}\n"
+ "\\beta_{1} + \\beta_{2}f_{2} & f_{2}\\leq \\gamma\\\\\n"
+ "\\beta_{1} + \\beta_{2}\\gamma + \\beta_{4}(f_{2}-\\gamma) & f_{2} >\\gamma\n"
+ "\\end{cases}sdsdssd,\n"
+ "\\end{equation}}'\n\n"
+ "blablablaba {}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}