const regex = /\{([\s\S]*equation\})\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{([\\s\\S]*equation\\})\\}', 'g')
const str = `\$str='\\add[sometext]{\\begin{equation}\\label{eqn:3}
f_{1} =
\\begin{cases}}
\\beta_{1} + \\beta_{2}f_{2} & f_{2}\\leq \\gamma\\\\
\\beta_{1} + \\beta_{2}\\gamma + \\beta_{4}(f_{2}-\\gamma) & f_{2} >\\gamma
\\end{cases}sdsdssd,
\\end{equation}}'
blablablaba {}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}