# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\{([\s\S]*equation\})\}"
test_str = ("$str='\\add[sometext]{\\begin{equation}\\label{eqn:3}\n"
"f_{1} =\n"
"\\begin{cases}}\n"
"\\beta_{1} + \\beta_{2}f_{2} & f_{2}\\leq \\gamma\\\\\n"
"\\beta_{1} + \\beta_{2}\\gamma + \\beta_{4}(f_{2}-\\gamma) & f_{2} >\\gamma\n"
"\\end{cases}sdsdssd,\n"
"\\end{equation}}'\n\n"
"blablablaba {}")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.