re = /\{([\s\S]*equation\})\}/
str = '$str=\'\\add[sometext]{\\begin{equation}\\label{eqn:3}
f_{1} =
\\begin{cases}}
\\beta_{1} + \\beta_{2}f_{2} & f_{2}\\leq \\gamma\\\\
\\beta_{1} + \\beta_{2}\\gamma + \\beta_{4}(f_{2}-\\gamma) & f_{2} >\\gamma
\\end{cases}sdsdssd,
\\end{equation}}\'
blablablaba {}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end