using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"color.*?(?<COLOR>(red|blue|black|Gree)).*?.";
string input = @"favorite colors are red, blue and black. Mr. Green
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}