$re = '/color.*?(?<COLOR>(red|blue|black|Gree)).*?./';
$str = 'favorite colors are red, blue and black. Mr. Green
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);