re = /color.*?(?<COLOR>(red|blue|black|Gree)).*?./
str = 'favorite colors are red, blue and black. Mr. Green
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end