const regex = /color.*?(?<COLOR>(red|blue|black|Gree)).*?./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('color.*?(?<COLOR>(red|blue|black|Gree)).*?.', '')
const str = `favorite colors are red, blue and black. Mr. Green
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}