package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`color.*?(?<COLOR>(red|blue|black|Gree)).*?.`)
var str = `favorite colors are red, blue and black. Mr. Green
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}