using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{[^}]* \|[^|}]*}";
string input = @" // Löscht einen Interessenten
function setStatus(id, status) {
if (status == 'del') {
if (confirmotm(""{/literal}{$msg.dg|escape:""nestedjs""}{literal}"")) {
$('action').value = 'del|'+id;
$('searchform').submit();
}
}
else if (status == 'lock') {
if (confirmotm(""{/literal}{$msg.dk |escape:""nestedjs""}{literal}"")) {
$('action').value = 'lock|'+id;
$('searchform').submit();
}
}
{ elseif $countryID == 'US' || $countryID == 'CA' || $countryID == 'AU' }
else if (status == 'enable') {
$('action').value = 'enable|'+id;
$('searchform').submit();
}
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}