# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{[^}]* \|[^|}]*}"
test_str = (" // Löscht einen Interessenten\n"
" function setStatus(id, status) {\n"
" if (status == 'del') {\n"
" if (confirmotm(\"{/literal}{$msg.dg|escape:\"nestedjs\"}{literal}\")) {\n"
" $('action').value = 'del|'+id;\n"
" $('searchform').submit();\n"
" }\n"
" }\n"
" else if (status == 'lock') {\n"
" if (confirmotm(\"{/literal}{$msg.dk |escape:\"nestedjs\"}{literal}\")) {\n"
" $('action').value = 'lock|'+id;\n"
" $('searchform').submit();\n"
" }\n"
" }\n"
"{ elseif $countryID == 'US' || $countryID == 'CA' || $countryID == 'AU' }\n"
" else if (status == 'enable') {\n"
" $('action').value = 'enable|'+id;\n"
" $('searchform').submit();\n"
" }\n"
" }")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.