import Foundation
let pattern = #"{[^}]* \|[^|}]*}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
			// Löscht einen Interessenten
			function setStatus(id, status) {
				if (status == 'del') {
					if (confirmotm("{/literal}{$msg.dg|escape:"nestedjs"}{literal}")) {
						$('action').value = 'del|'+id;
						$('searchform').submit();
					}
				}
				else if (status == 'lock') {
					if (confirmotm("{/literal}{$msg.dk |escape:"nestedjs"}{literal}")) {
						$('action').value = 'lock|'+id;
						$('searchform').submit();
					}
				}
{ elseif $countryID == 'US' || $countryID == 'CA' || $countryID == 'AU' }
				else if (status == 'enable') {
					$('action').value = 'enable|'+id;
					$('searchform').submit();
				}
			}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)