package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{[^}]* \|[^|}]*}`)
var str = ` // Löscht einen Interessenten
function setStatus(id, status) {
if (status == 'del') {
if (confirmotm("{/literal}{$msg.dg|escape:"nestedjs"}{literal}")) {
$('action').value = 'del|'+id;
$('searchform').submit();
}
}
else if (status == 'lock') {
if (confirmotm("{/literal}{$msg.dk |escape:"nestedjs"}{literal}")) {
$('action').value = 'lock|'+id;
$('searchform').submit();
}
}
{ elseif $countryID == 'US' || $countryID == 'CA' || $countryID == 'AU' }
else if (status == 'enable') {
$('action').value = 'enable|'+id;
$('searchform').submit();
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}