$re = '/{[^}]* \|[^|}]*}/';
$str = ' // Löscht einen Interessenten
function setStatus(id, status) {
if (status == \'del\') {
if (confirmotm("{/literal}{$msg.dg|escape:"nestedjs"}{literal}")) {
$(\'action\').value = \'del|\'+id;
$(\'searchform\').submit();
}
}
else if (status == \'lock\') {
if (confirmotm("{/literal}{$msg.dk |escape:"nestedjs"}{literal}")) {
$(\'action\').value = \'lock|\'+id;
$(\'searchform\').submit();
}
}
{ elseif $countryID == \'US\' || $countryID == \'CA\' || $countryID == \'AU\' }
else if (status == \'enable\') {
$(\'action\').value = \'enable|\'+id;
$(\'searchform\').submit();
}
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);