import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+\\w+\\[(?<first_num>\\d+)\\]\\w+\\[(?<second_num>\\d+)\\][^\\[]*\\[(?<third_num>[^\\]]*)\\]";
final String string = "1:00:00 jon nginx: A[1234]B[56789] [0.1222]\n"
+ " \n"
+ " 11:00:00 dan service cloud: C[0078]D[12] F[2]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}