import re
regex = re.compile(r"\s+\w+\[(?<first_num>\d+)\]\w+\[(?<second_num>\d+)\][^\[]*\[(?<third_num>[^\]]*)\]", flags=re.MULTILINE)
test_str = ("1:00:00 jon nginx: A[1234]B[56789] [0.1222]\n"
" \n"
" 11:00:00 dan service cloud: C[0078]D[12] F[2]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")