const regex = /\s+\w+\[(?<first_num>\d+)\]\w+\[(?<second_num>\d+)\][^\[]*\[(?<third_num>[^\]]*)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+\\w+\\[(?<first_num>\\d+)\\]\\w+\\[(?<second_num>\\d+)\\][^\\[]*\\[(?<third_num>[^\\]]*)\\]', 'gm')
const str = `1:00:00 jon nginx: A[1234]B[56789] [0.1222]
11:00:00 dan service cloud: C[0078]D[12] F[2]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}