$re = '/\s+\w+\[(?<first_num>\d+)\]\w+\[(?<second_num>\d+)\][^\[]*\[(?<third_num>[^\]]*)\]/m';
$str = '1:00:00 jon nginx: A[1234]B[56789] [0.1222]
11:00:00 dan service cloud: C[0078]D[12] F[2]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);