using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([!-\~]*[aeiou][!-\~]*)";
string input = @"a b c d e f g h i j k l m n o p q r s t u v w x y z
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
stale
egg
bunnul
f
dfdfdfdf
bfbgfgf
gbvcb
bvvb
v bnbv
b'sfgr2345092374
hjjjio
1234ABNGH
23123ibnnbiuysd
i
aaaaaaaaaaaaaaaaaa
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}