$re = '/([!-\~]*[aeiou][!-\~]*)/i';
$str = 'a b c d e f g h i j k l m n o p q r s t u v w x y z
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
stale
egg
bunnul
f
dfdfdfdf
bfbgfgf
gbvcb
bvvb
v bnbv
b\'sfgr2345092374
hjjjio
1234ABNGH
23123ibnnbiuysd
i
aaaaaaaaaaaaaaaaaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);