// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([!-\~]*[aeiou][!-\~]*)").unwrap();
let string = "a b c d e f g h i j k l m n o p q r s t u v w x y z
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
stale
egg
bunnul
f
dfdfdfdf
bfbgfgf
gbvcb
bvvb
v bnbv
b'sfgr2345092374
hjjjio
1234ABNGH
23123ibnnbiuysd
i
aaaaaaaaaaaaaaaaaa
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}