import re
regex = re.compile(r"([!-\~]*[aeiou][!-\~]*)", flags=re.IGNORECASE)
test_str = ("a b c d e f g h i j k l m n o p q r s t u v w x y z\n"
"A B C D E F G H I J K L M N O P Q R S T U V W X Y Z\n\n"
"stale\n"
"egg\n\n"
"bunnul\n\n\n\n"
"f\n"
"dfdfdfdf\n"
"bfbgfgf\n"
"gbvcb \n"
"bvvb \n"
"v bnbv\n"
"b'sfgr2345092374\n\n"
"hjjjio\n\n"
"1234ABNGH\n\n"
"23123ibnnbiuysd\n"
"i\n\n\n"
"aaaaaaaaaaaaaaaaaa\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")