#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^'?([a-z]+((\. )|( ')|['\- \.])?)+$"
Local $sString = "John Doe" & @CRLF & _
"John Doe" & @CRLF & _
"John''---Doe" & @CRLF & _
"Jo'''hn Doe" & @CRLF & _
"''Johne" & @CRLF & _
"'John Doe" & @CRLF & _
"John-Doe" & @CRLF & _
"John'Doe" & @CRLF & _
"John.Doe" & @CRLF & _
"Jon..Doe" & @CRLF & _
"John.Doe.The.Third" & @CRLF & _
"J.Doe" & @CRLF & _
"Joh N Doe" & @CRLF & _
"Jo -N" & @CRLF & _
"'" & @CRLF & _
"'N" & @CRLF & _
"' John" & @CRLF & _
"John,.Doe" & @CRLF & _
"J. Doe" & @CRLF & _
"J .Do" & @CRLF & _
"J- D" & @CRLF & _
"J' Doe" & @CRLF & _
"J .Do" & @CRLF & _
"J -Doe" & @CRLF & _
"J Doe" & @CRLF & _
"J..D" & @CRLF & _
"J.-Doe" & @CRLF & _
"John Doe M. R." & @CRLF & _
"O 'Brien"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")