using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^'?([a-z]+((\. )|( ')|['\- \.])?)+$";
string input = @"John Doe
John Doe
John''---Doe
Jo'''hn Doe
''Johne
'John Doe
John-Doe
John'Doe
John.Doe
Jon..Doe
John.Doe.The.Third
J.Doe
Joh N Doe
Jo -N
'
'N
' John
John,.Doe
J. Doe
J .Do
J- D
J' Doe
J .Do
J -Doe
J Doe
J..D
J.-Doe
John Doe M. R.
O 'Brien";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}