const regex = /^'?([a-z]+((\. )|( ')|['\- \.])?)+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\'?([a-z]+((\\. )|( \')|[\'\\- \\.])?)+$', 'gmi')
const str = `John Doe
John Doe
John''---Doe
Jo'''hn Doe
''Johne
'John Doe
John-Doe
John'Doe
John.Doe
Jon..Doe
John.Doe.The.Third
J.Doe
Joh N Doe
Jo -N
'
'N
' John
John,.Doe
J. Doe
J .Do
J- D
J' Doe
J .Do
J -Doe
J Doe
J..D
J.-Doe
John Doe M. R.
O 'Brien`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}