use strict;
my $str = 'John Doe
John Doe
John\'\'---Doe
Jo\'\'\'hn Doe
\'\'Johne
\'John Doe
John-Doe
John\'Doe
John.Doe
Jon..Doe
John.Doe.The.Third
J.Doe
Joh N Doe
Jo -N
\'
\'N
\' John
John,.Doe
J. Doe
J .Do
J- D
J\' Doe
J .Do
J -Doe
J Doe
J..D
J.-Doe
John Doe M. R.
O \'Brien';
my $regex = qr/^'?([a-z]+((\. )|( ')|['\- \.])?)+$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}