re = /^'?([a-z]+((\. )|( ')|['\- \.])?)+$/mi
str = 'John Doe
John Doe
John\'\'---Doe
Jo\'\'\'hn Doe
\'\'Johne
\'John Doe
John-Doe
John\'Doe
John.Doe
Jon..Doe
John.Doe.The.Third
J.Doe
Joh N Doe
Jo -N
\'
\'N
\' John
John,.Doe
J. Doe
J .Do
J- D
J\' Doe
J .Do
J -Doe
J Doe
J..D
J.-Doe
John Doe M. R.
O \'Brien'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end