#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.+)\..+$"
Local $sString = "index.min.html" & @CRLF & _
"index.dev.html(1)" & @CRLF & _
"index.min.js" & @CRLF & _
"index.dev.js" & @CRLF & _
"There.are.also.files.with.multiple.dots.and.other.extension"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")