re = /(.+)\..+$/m
str = 'index.min.html
index.dev.html(1)
index.min.js
index.dev.js
There.are.also.files.with.multiple.dots.and.other.extension'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end