package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+)\..+$`)
var str = `index.min.html
index.dev.html(1)
index.min.js
index.dev.js
There.are.also.files.with.multiple.dots.and.other.extension`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}