$re = '/(.+)\..+$/m';
$str = 'index.min.html
index.dev.html(1)
index.min.js
index.dev.js
There.are.also.files.with.multiple.dots.and.other.extension';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);