// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.+)\..+$").unwrap();
let string = "index.min.html
index.dev.html(1)
index.min.js
index.dev.js
There.are.also.files.with.multiple.dots.and.other.extension";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}