package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^|\.)\s*([0-9]{4})\s*(\.|$)`)
var str = `Lastname, Firstname. 1900. Title: 1920-1930. etc.
Lastname, Firstname. 1900. Title etc.
1900. Lastname. Firstname
Lastname, Firstname. 1900`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}