re = /(^|\.)\s*([0-9]{4})\s*(\.|$)/m
str = 'Lastname, Firstname. 1900. Title: 1920-1930. etc.
Lastname, Firstname. 1900. Title etc.
1900. Lastname. Firstname
Lastname, Firstname. 1900'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end