import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\.)\\s*([0-9]{4})\\s*(\\.|$)";
final String string = "Lastname, Firstname. 1900. Title: 1920-1930. etc.\n"
+ "Lastname, Firstname. 1900. Title etc.\n"
+ "1900. Lastname. Firstname\n"
+ "Lastname, Firstname. 1900";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}