const regex = /(^|\.)\s*([0-9]{4})\s*(\.|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\.)\\s*([0-9]{4})\\s*(\\.|$)', 'gm')
const str = `Lastname, Firstname. 1900. Title: 1920-1930. etc.
Lastname, Firstname. 1900. Title etc.
1900. Lastname. Firstname
Lastname, Firstname. 1900`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}