$re = '/(^|\.)\s*([0-9]{4})\s*(\.|$)/m';
$str = 'Lastname, Firstname. 1900. Title: 1920-1930. etc.
Lastname, Firstname. 1900. Title etc.
1900. Lastname. Firstname
Lastname, Firstname. 1900';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);