# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"?(\w+)='?([\w]+)'?"?|"?(\w+)="([\w\s]+)""?/"$1$3='$2$4'"/g;t' <<< "foo a='b' c=\"d and e\" wombat=true a fizz='buzz' \"hello='goodbye'\""