using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""?(\w+)='?([\w]+)'?""?|""?(\w+)=""([\w\s]+)""?";
string substitution = @"""$1$3='$2$4'""";
string input = @"foo a='b' c=""d and e"" wombat=true a fizz='buzz' ""hello='goodbye'""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}