const regex = /"?(\w+)='?([\w]+)'?"?|"?(\w+)="([\w\s]+)""?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"?(\\w+)=\'?([\\w]+)\'?"?|"?(\\w+)="([\\w\\s]+)""?', 'g')
const str = `foo a='b' c="d and e" wombat=true a fizz='buzz' "hello='goodbye'"`;
const subst = `"$1$3='$2$4'"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);