#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""?(\w+)='?([\w]+)'?"?|"?(\w+)="([\w\s]+)""?"
Local $sString = "foo a='b' c="d and e" wombat=true a fizz='buzz' "hello='goodbye'""
Local $sSubst = ""$1$3='$2$4'""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)