$re = '/"?(\w+)=\'?([\w]+)\'?"?|"?(\w+)="([\w\s]+)""?/';
$str = 'foo a=\'b\' c="d and e" wombat=true a fizz=\'buzz\' "hello=\'goodbye\'"';
$subst = "\"$1$3='$2$4'\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;