#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?U)\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}"
Local $sString = "Some example text with \added[author]{text with curly braces{some text}..}" & @CRLF & _
"" & @CRLF & _
"Some example text with \added[author]{text without curly braces}" & @CRLF & _
"" & @CRLF & _
"Some example text with \added[author]{text with {}and {} and {}curly braces{some text}..}" & @CRLF & _
"" & @CRLF & _
"Some example text with \added[author]{text with {}and {} and {}curly braces{some text}..}}" & @CRLF & _
"" & @CRLF & _
"Some example text with \added[author]{text with {}and {} and {}curly braces{some text}..}{}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")