const regex = /\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\added\\[.*\\]\\{(.*(?:\\{.*\\}.*)*)\\}', 'g')
const str = `Some example text with \\added[author]{text with curly braces{some text}..}
Some example text with \\added[author]{text without curly braces}
Some example text with \\added[author]{text with {}and {} and {}curly braces{some text}..}
Some example text with \\added[author]{text with {}and {} and {}curly braces{some text}..}}
Some example text with \\added[author]{text with {}and {} and {}curly braces{some text}..}{}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}