re = /\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}/
str = 'Some example text with \\added[author]{text with curly braces{some text}..}
Some example text with \\added[author]{text without curly braces}
Some example text with \\added[author]{text with {}and {} and {}curly braces{some text}..}
Some example text with \\added[author]{text with {}and {} and {}curly braces{some text}..}}
Some example text with \\added[author]{text with {}and {} and {}curly braces{some text}..}{}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end