package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)\\added\[.*\]\{(.*(?:\{.*\}.*)*)\}`)
var str = `Some example text with \added[author]{text with curly braces{some text}..}
Some example text with \added[author]{text without curly braces}
Some example text with \added[author]{text with {}and {} and {}curly braces{some text}..}
Some example text with \added[author]{text with {}and {} and {}curly braces{some text}..}}
Some example text with \added[author]{text with {}and {} and {}curly braces{some text}..}{}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}